首页 加入收藏

虚拟路由器冗余性协议--VRRP

2015年07月10日 15:16供稿中心: 课工场
摘要:VRRP提供了与HSRP(热备份路由协议)类似的路由器故障倒换方法,但VRRP属于开放式协议。与HSRP相同,VRRP也是由一组路由器组成单一的虚拟路由器。

VRRPVRRP(虚拟路由器冗余性协议)

在一个HSRP或VRRP组中,选举出一台路由器来负责处理发送到虚拟IP地址的所有请求

在HSRP中,这台路由器称为活跃路由器。一个HSRP组中有一台活跃路由器、一台备用路由器、可能有很多台监听路由器。而一个VRRP组中有一台主用(master)路由器,以及一台或多台备用(backup)路由器。

HSRP与VRRP之间的比较

  
HSRP
  
VRRP
HSRP属于cisco私有协议
VRRP属于IEEE标准协议(开放式)
最多支持16个组
最多支持255个组
1个活跃路由器、1个备份路由器、若干个监听路由器
1个活跃路由器、若干个备份路由器
虚拟IP地址与活跃路由器和备用路由器等的真实IP地址不同
虚拟IP地址可以与其中一个组成员的真实IP地址相同
使用224.0.0.2发送hello数据包
使用224.0.0.18发送hello数据包
默认计时器:hello时间3秒,保持时间10秒
VRRP中的默认计时器小于HSRP。从而使VRRP故障倒换速度快于HSRP。
可以追踪接口或对象
只可以追踪对象
默认在每个组中使用认证。当管理员没有对认证进行配置时,默认以cisco为密码进行认证
支持明文认证和HMAC/MD5认证方式。

VRRP的冗余性

Ø  VRRP可以为路由器真实IP地址提供冗余性,或者也可以为VRRP组成员共享的虚拟IP地址提供冗余性。

Ø  如果管理员使用了真实IP地址,那么配置了该地址的路由器就会成为主用路由器。如果管理员使用了虚拟IP地址,那么具有最高的优先级成为主用路由器。

Ø 一个VRRP组中有1个主用路由器,以及一个或多个备用路由器。主用路由器使用VRRP消息来通知组成员它的主用角色。


VRRP的优先级

对于将VRRP组IP地址设置为某个组成员物理接口IP地址,拥有该IP地址的路由器将成为该组的主用路由器。它的优先级设置为255.备用路由器的优先级范围可以使1-254,默认值为100。优先级值0有特殊意义,它表示当前的主用路由器以不参与VRRP的运作。这个设置可以用来触发备用路由器快速过渡到主用模式,而无需等待当前的主用路由器超时。


VRRP计时器

当主用路由器变为不可用时,VRRP中的动态切换机制会用到三个计时器:公告间隔、主用失效间隔时间、时滞时间。

Ø  公告间隔:是指主用路由器发送公告消息的时间间隔(秒为单位)。默认间隔为1秒。

Ø  主用失效间隔:是指备用路由器认为主用失效的时间间隔(秒为单位)。默认间隔是时间的计算方式为3 x 公告间隔 + 时滞时间

Ø 时滞时间:计算方式为(256- 优先级/256)毫秒,它确保了具有最高优先级的备用路由器成为新的主用路由器。


注意:
    在VRRP主用路由器正常关机的案例中,它会以优先级0发送公告信息。这个优先级设置会触发备用路由器快速接管主用路由器的工作,只需等待时滞时间,而无需等待主用失效间隔时间。
   HSRP和VRRP最主要的区别在于,VRRP中的备用路由器不发送公告信息,因此VRRP主用路由器无法感知当前的备份路由器

VRRP配置案例

拓扑图:

实验思路:

1、sw1、sw2、sw3个相连的端口配置为trunk

2、在每台交换机中添加vlan 10

3、将sw3的f0/0端口加入到vlan10中

4、在sw1和sw2中配置SVI虚接口,并配置VRRP

5、配置host1将默认网关指向vrrp配置的虚拟IP

6、验证主用路由器down后,host1还能正常访问网络


1

SW1(config)#doshint trunk

Port     Mode         Encapsulation  Status       Native vlan
Fa0/0    on           802.1q         trunking      1
Fa0/1    on           802.1q         trunking      1
---------------------------------------------------------------------
SW2(config)#doshint trunk

Port     Mode         Encapsulation  Status       Native vlan
Fa0/0    on           802.1q         trunking      1
Fa0/1    on           802.1q         trunking      1
---------------------------------------------------------------------

SW3(config)#doshint trunk

Port     Mode         Encapsulation  Status       Native vlan
Fa0/1    on           802.1q         trunking      1

Fa0/2    on           802.1q         trunking      1


2

SW1#vlandatabase   ---进入vlan数据库中配置vlan(这个属于旧配置方法)
SW1(vlan)#vlan 10    ---添加vlan 10
VLAN 10 added:
   Name: VLAN0010
SW1(vlan)#exit      ---退出并保存配置
APPLY completed.
Exiting....
SW1#
---------------------------------------------------------------------

【sw2和sw3上的配置与上述配置相同】


3

SW3(config)#int f0/0----进入f0/0接口
SW3(config-if)#switchport mode access    ---将该接口配置为access模式
SW3(config-if)#switchport access vlan 10 ---将该接口加入到vlan  10中
SW3(config-if)#exit
SW3(config)#   

SW3(config)#do shvlan-s

VLAN Name                             Status    Ports
---------------------------------------------------------------------
1   default                         active    Fa0/3, Fa0/4, Fa0/5, Fa0/6、Fa0/7, Fa0/8, Fa0/9, Fa0/10、Fa0/11, Fa0/12,Fa0/13, Fa0/14、Fa0/15

10   VLAN0010                         active    Fa0/0


4

虚接口的配置:
SW1(config)#do shrun int vlan 10
Building configuration...

Current configuration : 63 bytes
!
interface Vlan10
ip address 192.168.10.1255.255.255.0
end

SW1(config)#
---------------------------------------------------------------------

SW2(config)#do shrun int vlan 10
Building configuration...

Current configuration : 63 bytes
!
interface Vlan10
ip address 192.168.10.2255.255.255.0
end

SW2(config)#

VRRP的配置:
SW1(config)#do sh run intvlan 10
Building configuration...

Current configuration : 119 bytes
!
interface Vlan10
ip address 192.168.10.1 255.255.255.0
vrrp 10 ip 192.168.10.254  ---在接口上启用VRRP,该命令使接口成为使用这个虚拟IP地址的虚拟组的成员;10代表组号、192.168.10.254代表此VRRP组使用的IP地址(可以为虚拟IP也可以为其真实的物理IP地址)
vrrp 10 timers advertise msec 500 ----更改计时器,计时器参数指明设备作为主用主用路由器的公告间隔。(这里为500毫秒)
vrrp 10 priority 200    ----设置VRRP组此台路由器的优先级;具有最高的优先级为主用路由器。如果多台路由器的优先级相同,那么具有最高真实IP地址的网关通过选举成为主用路由器。
end

SW1(config)
---------------------------------------------------------------------

SW2(config)#do sh run intvlan 10
Building configuration...

Current configuration : 134 bytes
!
interface Vlan10
ip address 192.168.10.2 255.255.255.0
vrrp 10 ip 192.168.10.254
vrrp 10 timers learn   ----的意思就是从主路由器那里获悉VRRP通告时间间隔,一般是从路由器才这样配置的
vrrp 10 priority 150
end

SW2(config)#
验证:
  
SW1(config)#do  shvrrp brief
  
Interface          Grp Pri Time  Own Pre State   Master addr     Group addr
  
Vl10               10  200 1718       Y   Master  192.168.10.1    192.168.10.254
  
SW1(config)#
  
SW2(config)#do  shvrrp brief
  
Interface          Grp Pri Time  Own Pre State   Master addr     Group addr
  
Vl10               10  150 3414       Y   Backup  192.168.10.1    192.168.10.254
  
SW2(config)#

5

6

将sw1的vlan 10(或f0/1口)给shutdown掉
SW1(config)#intvlan 10
SW1(config-if)#shutdown
---------------------------------------------------------------------

再使用host1的ping测试:(pingsw2能够ping通,而sw1无法ping通)


  • 相关阅读
linux技术开发介绍2015.08.31
如何安装虚拟机VMware2015.08.28
虚拟机的安装和使用2015.08.25
Linux系统:关于压缩软件gzip和xz的简单对比2015.08.20
流媒体发展新趋势 对等网络技术(P2P)2015.08.19
  • 全国校区查询
  • 技术分享点击榜
  • 技术分享最新文章
  • 热门标签
关于我们
公司简介
发展历程
青鸟荣誉
联系我们
加入我们
青鸟课程
ACCP
学士后Java
BENET
网络营销
启蒙星IT工程师基础课程
学习客户端下载
青鸟优师
青鸟微讯
学士后Android软件工程师
网络营销师1.0
关注我们
RSS订阅
北大青鸟网络营销学院
北大青鸟学员社区
北大青鸟官方微信
北大青鸟微社区
回顶部 新版反馈 回到首页
官方新版意见收集

*

官方新版意见收集

提交成功,感谢您的反馈。

我们会认真阅读和考虑每个用户的反馈。